Thursday, May 21, 2015

X Forwarding issue with Mac OS X

If you try to remote access a Linux application from your Mac, you will certainly face the following issue : Forwarded X application window will be limited to the two thirds of your screen.
So you won't be able to drag the window out of the two thirds of the screen.

The issue has been reported here https://xquartz.macosforge.org/trac/ticket/2116, the workaround is to disable the "Displays have separate Spaces" option in Mission Control Preferences on your Mac.

Thursday, April 9, 2015

How to write on NTFS disk on Mac OS X Yosemite

Here is the best and simpler way to allow write on NTFS partition on my Mac OS X, you should follow exactly what's described in https://github.com/osxfuse/osxfuse/wiki/NTFS-3G and it will work like a charm !

Have fun,

Tuesday, March 24, 2015

How to mount and umount an iso image from the command line on Mac OS

How to mount an iso image from the command line on Mac OS :
# hdiutil mount SUSE_Manager_Server.x86_64-2.1.0.iso /dev/disk3 /Volumes/KIWI CD_DVD Installation
Here you go, your iso image will be mount in /Volumes/ . If needed here is how to list your disks :
# diskutil list /dev/disk0 #: TYPE NAME SIZE IDENTIFIER 0: GUID_partition_scheme *251.0 GB disk0 1: EFI EFI 209.7 MB disk0s1 2: Apple_CoreStorage 250.1 GB disk0s2 3: Apple_Boot Recovery HD 650.0 MB disk0s3 /dev/disk1 #: TYPE NAME SIZE IDENTIFIER 0: Apple_HFS Macintosh HD *249.8 GB disk1 Logical Volume on disk0s2 /dev/disk2 #: TYPE NAME SIZE IDENTIFIER 0: GUID_partition_scheme *1.0 TB disk2 1: EFI EFI 209.7 MB disk2s1 2: Apple_HFS WDOUILLE 900.0 GB disk2s2 3: Microsoft Basic Data FATOUILLE 99.8 GB disk2s3 /dev/disk3 #: TYPE NAME SIZE IDENTIFIER 0: KIWI CD_DVD Install... *611.4 MB disk3
To unmount your iso from the cli :
# hdiutil eject /dev/disk3 "disk3" unmounted. "disk3" ejected.

Wednesday, March 18, 2015

Installing Virtualbox Guest Additions on SUSE Linux Enterprise Server 12 and 15

 This article is not a complete and detailed how to, but will covered the subtlety of installing and using the Virtualbox Guest Additions (or Virtualbox Tools) on SUSE Linux Enterprise Server 12 SPX and SUSE Linux Enterprise Server 15 SPX.

Requirement:
Packages : gcc make kernel-default-devel
And of course you need to add the CD image of the Virtualbox Guest Additions in your SLES Virtual Machine :
Devices -> Insert Guest Additions CD image

Step :
1) Mount the cd image:
# mount /dev/sr0 /mnt


2) Install the package requirement:
# zypper in gcc kernel-default-devel

3) Enable "unsupported modules" to be loaded in the SLES's kernel:
Edit /etc/modprobe.d/10-unsupported-modules.conf
and set: allow_unsupported_modules 1
 
4) Run the Virtualbox Guest Additions installation script:
# cd /mnt
# ./VBoxLinuxAdditions.run
Verifying archive integrity... All good.
Uncompressing VirtualBox 5.0.14 Guest Additions for Linux............
VirtualBox Guest Additions installer
Copying additional installer modules ...
Installing additional modules ...
Removing existing VirtualBox non-DKMS kernel modules                  done
Building the VirtualBox Guest Additions kernel modules
Building the main Guest Additions module                              done
Building the shared folder support module                             done
Building the OpenGL support module                                    done
Doing non-kernel setup of the Guest Additions                         done
You should restart your guest to make sure the new modules are actually used

Installing the Window System drivers
Installing X.Org Server 1.15 modules                                  done
Setting up the Window System to use the Guest Additions               done
You may need to restart the hal service and the Window System (or just restart
the guest system) to enable the Guest Additions.

Installing graphics libraries and desktop services components         done

5) You can now reboot your system and check the if the new modules are used:
# reboot
and then after the reboot: 
# lsmod | grep vbox vboxsf                 47920  0 vboxvideo              12669  1 drm                   322623  2 vboxvideo vboxguest             298126  3 vboxsf

6) VoilĂ  !